Firefox acabará con los plugins NPAPI excepto Flash

Firefox acabará con los plugins NPAPI excepto Flash

Miguel Regueira |

Los plugins NPAPI son los más antiguos y rudimentarios en Internet, que nacieron en 1995 de la mano del antiguo navegador Netscape, de hecho su nombre significa Netscape Plugin Application Programming Interface. Pues bien, Firefox acabará con todos los plugins NPAPI excepto con Flash, así que dentro de poco más de un año tendremos que olvidarnos de ellos.

Cuando termine el 2016 dejarán de soportarse los plugins NPAPI, entre los que se encuentran Silverlight y Java. Flash se mantendrá porque aún es muy usado, aunque realmente también resultaría deseable librarse de él. En el pasado los pluings NPAPI permitían añadir sonidos, vídeos e interactividad en las páginas web, pero a día de hoy no hace falta recurrir a esta tecnología.

HTML5 suele ser capaz de cumplir con la mayoría de las funciones de estos plugins, de forma intercompatible y abierta. Además, HTML5 no supone los graves problemas de seguridad y rendimiento de estos componentes tan antiguos. Así que el camino es la renovación, no cabe duda.

Imagen - Firefox acabará con los plugins NPAPI excepto Flash

Flash es el siguiente

Los plugins NPAPI ya se han eliminado o limitado en muchos navegadores, como Chrome o Microsoft Edge. Sin embargo, incluso Adobe Flash ha sufrido problemas de seguridad muy graves, así que está claro que este movimiento lo deja en una posición cada vez más débil. Muchas voces claman por su eliminación desde hace tiempo.

De hecho, hasta YouTube ha dejado de usar Flash, y los diseñadores de páginas tiene claro que esta tecnología va a desaparecer en el futuro. Respecto a los plugins de Java y Silverlight, nunca fueron muy utilizados, en especial el último, y en años recientes su presencia en Internet ha sido testimonial.

Así que Firefox acabará con los plugins NPAPI excepto Flash, y todos navegaremos más seguros en Internet. Desde luego, se trata de una decisión dura, pero había que tomarla.

¿Qué opinas de este tema? ¿Consideras un error que Firefox deje de soportar los pluings NPAPI, o más bien representa una medida necesaria?

Ver Comentarios